Shopping Cart

Your cart is currently empty.

Why can't I find Wireless Charge Connection on my HybridX Compact?

Posted by Adam Heelis on

SINGLE COMPACT HYBRIDX

There are many variables involved, so we must narrow down the cause. Please follow the following steps.

1.Confirm that the Charger HUB is operating sufficiently? Is the blue power light illuminated? Can you charge a device via each of the ports with direct cable connection?

2.If this is all OK, we need to check the wireless pad performance. The pad can be removed from the top tray. Test the pad directly onto a wireless device. Remember to slide the device slowly towards the top of the pad while searching for induction.  Our charging coils are slightly higher offset in the naked wireless pad for optimal performance in our docks. (Illistrated Below)

 3.If you are successful in achieving connection, we possibly have an issue with devices position on the ALLDOCK when seeking connection. We recommend you experiment the position of your device on the front deck. Ensure the device runs parallel with deck and stays 100% on the deck surface. In the single wireless format, you will find generally and positioning is central on the centre of the deck.

 As the Alldock Deck is a large surface area, what is important is the phone is positioned directly across the internal wireless coils. The coils do not cover the entire deck so positioning is imperative. (but not a difficult process)

 After a number of times creating successful connection we are certain you will build confidence in the ideal position. We also recommend you wait approx 5 seconds when charge is initiated to ensure a secure induction charge continues.


Older Post Newer Post